DeprecationWarning: portage.dep.dep_getkey() is deprecated

Después de unos de los updates me salio este error, que no le había hecho caso hasta ahora, que me dio por ver y es el bug 303519 que hace referencia a los warnings deprecation python....

$ Kaiser ~ # emerge -DuNa world

These are the packages that would be merged, in order:

Calculating dependencies -/usr/lib64/portage/pym/portage/dep.py:931: DeprecationWarning: portage.dep.dep_getkey() is deprecated, use portage.dep.Atom.cp instead
DeprecationWarning)
/usr/lib64/portage/pym/portage/dep.py:695: DeprecationWarning: portage.dep.dep_getcpv() is deprecated, use portage.dep.Atom.cpv instead
DeprecationWarning)
... done!

Y bueno, solo hay que actualizar el portage a la versión 2.1.7.17 y problema solucionado. :-Ð